eclipse

Momentics IDE Crash on Kubuntu 13.10

Posted on

If you are a Blackberry developer and Kubuntu user like me, may be you get your Momentics IDE crash on Kubuntu 13.10. Something like:

#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0xf3cc2bfe, pid=5094, tid=4149470912
#
# JRE version: 6.0_43-b01                                                                                                                                                        
# Java VM: Java HotSpot(TM) Client VM (20.14-b01 mixed mode, sharing linux-x86 )                                                                                                 
# Problematic frame:                                                                                                                                                             
# C  [libgobject-2.0.so.0+0x16bfe]  __float128+0x1e                                                                                                                              
#                                                                                                                                                                                
# An error report file with more information is saved as:                                                                                                                        
# /home/haikal/bin/bbndk/hs_err_pid5094.log                                                                                                                                      
#                                                                                                                                                                                
# If you would like to submit a bug report, please visit:
#   http://java.sun.com/webapps/bugreport/crash.jsp
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
Aborted (core dumped)

will appears if you did some action. On some cases, the problem was not “libgobject-2.0.so.0”, but “libgtk-x11-2.0.so.0+0” something. Here is the solution that works for me. Open System Settings > Application Appearance > GTK > Select a GTK2 Theme. Choose whatever you want, except “oxygen-gtk”. That’s it.

Mengaktifkan Autocomplete Pygtk di Eclipse

Posted on Updated on

pygtk-splash <<===========>>       eclipse_ide

Pada kasus ini saya menggunakan IDE Eclipse 3.2 di atas sistem Linux Debian 5.

Sebelumnya pastikan paket-paket berikut sudah terinstall.

  • eclipse (tentu saja :D)
  • python-gtk2
  • eclipse-pydev

Jalankan Eclipse. Buka menu Window –> Preferences –> Pydev –> Interpreter – Python. Di bagian ‘Forced builtin libs’, klik New dan tambahkan ‘gtk’, ‘gobject’, ‘atk’, dan ‘pango’ satu per satu. Klik Apply, OK.

screenshot-pydev-hellopy-eclipse-sdk